Simple upgrades

I decided to upgrade SpamAssassin to the current version earlier, something I have done on many occasions. Although this time the developers seem to have introduced an unannounced dependency on Perl 5.8, and consequently it took a violent dislike to my current installation of Perl 5.005 and refused to run, which had the knock-on effect of killing amavisd-new and leaving all my mail floating around in limbo.

This means a quick 2 minute upgrade has taken over an hour so far and it’s still broken.

This entry was posted in Tech. Bookmark the permalink.

2 Responses to Simple upgrades

  1. Chris says:

    Something smells wrong. Are you upgrading on FBSD using portupgrade? Which version were you upgrading to?

    Supposedly, everrything up to 2.69 Should support 5.005 and 5.6.1:

    The SpamAssassin 2.6x release series will be the last set of releases to
    officially support perl versions earlier than perl 5.6.0. If you are
    using an earlier release, you will need to upgrade when SpamAssassin 2.70
    is eventually released.

    I wouldn’t expect anything in it right now to contain 5.8.0 dependencies unless someone screwed up in the release.

  2. Rich says:

    Somebody screwed up somewhere.

    2.62 had “issues” with older versions of Perl, they were fixed in 2.63 which appeared a couple of days later.