Nightmare Night Ride

I headed out on the usual trip to Bradford and back tonight, however 10 miles out, part way along a particularly dark bit of canal, my front light decided to stop working. I turned back and managed to limp the 5 miles back to Bathampton where I could pick up the roads and more importantly some street lights in order to get home again.

I suspect that the Lumicycle battery needs replacing. It’s only on it’s third winter of use, but the Solstice HID lamp unit isn’t quite so tolerent of low voltages which I suspect is where the problem lies.

Update: I think I’d miscalculated how much I’d used the battery since it’d last been charged.

This entry was posted in Bikes. Bookmark the permalink.

6 Responses to Nightmare Night Ride

  1. grant says:

    Rich in problems spookily similar to Grant’s shock.

  2. rjw says:

    My lamp cuts out completely, then the blue LED on the switch flashes 10 times. It’ll restart if you wait a few seconds, but then cuts out again shortly afterwards.

    Was yours doing the same?

  3. Steve says:

    I finally got my backside in gear and cycled to work for the first time in years. I will probably now nod off whilst reading Lauren her bedtime story!

  4. alex says:

    i hope you pushed your bicycle all the way home if you didnt have the appropriate lights?

  5. rjw says:

    If I’d pushed, I’d still be somewhere the far side of Bathampton :)

  6. grant says:

    “My lamp cuts out completely, then the blue LED on the switch flashes 10 times. It’ll restart if you wait a few seconds, but then cuts out again shortly afterwards.

    Was yours doing the same?”

    Aye